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How to combine images
In Photoshop, you can use multiple layers to combine images, but there are two other great ways to 
create a single image from multiple photographs:

•	 Photomerge Create a panoramic image that combines several photographs into one 
continuous image. Photomerge can assemble photos that are tiled horizontally or vertically.

•	 High Dynamic Range (HDR) Create a image that combines multiple exposures into a single 
image to preserves the full tonal range of a scene.

Download the assets used in this tutorial here.

Creating a panoramic image

A panorama is a cinematic, often scenic image that captures a wide field of view (Figure 1). In Adobe Photoshop you 
can create panoramas by stitching together a series of photographic images. This guide shows you how to combine 
images automatically in Photoshop by using the Photomerge command.

Figure 1 Original images (top) and finished panoramic image (bottom)

http://adobe.ly/2gKFOjF
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Take pictures for use with Photomerge
Your source photographs play a large role in panoramic compositions. To avoid problems, follow these guidelines 
when taking pictures for use with Photomerge:

•	 Overlap images sufficiently. Images should overlap by approximately 40%. If the overlap is less, Photomerge 
may not be able to automatically assemble the panorama. However, keep in mind that the images shouldn’t 
overlap too much. If images overlap by 70% or more, Photomerge may not be able to blend the images. Try 
to keep the individual photos at least somewhat distinct from each other.

•	 Use one focal length. If you use a zoom lens, don’t change the focal length (zoom in or out) while taking 
your pictures.

•	 Keep the camera level. Although Photomerge can process slight rotations between pictures, a tilt of more 
than a few degrees can result in errors when the panorama is assembled. Using a tripod with a rotating head 
helps maintain camera alignment and viewpoint.

•	 Stay in the same position. Try not to change your position as you take a series of photographs, so that the 
pictures are from the same viewpoint. Using the optical viewfinder with the camera held close to the eye 
helps keep the viewpoint consistent. Or try using a tripod to keep the camera in the same place.

•	 Avoid using distortion lenses. Fish-eye and other distortion lenses can interfere with Photomerge.
•	 Maintain the same exposure. Avoid using the flash in some pictures and not in others. The blending features 

in Photomerge help smooth out different exposures, but extreme differences make alignment difficult. Some 
digital cameras change exposure settings automatically as you take pictures, so you may need to check your 
camera settings to be sure that all the images have the same exposure.

Photomerge and advanced blending
Advanced blending allows Photomerge to assess a series of images and find the ideal location to create a seam that 
serves as a transition from one image to another. Each image becomes a layer, with a mask applied to the blend seam. 
In Figure 2 you can see how six images are layered with advanced blending masks to stitch together the scene in 
Figure 1.

Creating a panorama by using Photomerge in Photoshop
To create a panorama, you need a series of scenic photographs that overlap slightly.

Figure 2 Layered images that make up the panorama in Figure 1, with one layer set to 70% opacity to show seams
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To create a panorama:

1.	 Choose File > Automate > Photomerge.

The Photomerge dialog box appears (Figure 3).

2.	 Select a Layout option.

•	Auto Photoshop chooses a Perspective or Cylindrical layout, depending on which produces a better photomerge.

•	Perspective Creates a consistent composition by designating one of the source images (by default, the middle 
image) as the reference image. The other images are then transformed (repositioned, stretched or skewed as 
necessary) so that overlapping content across layers is matched.

•	Cylindrical Reduces the “bow-tie” distortion that can occur with the Perspective layout by displaying individual 
images as on an unfolded cylinder. Overlapping content across layers is still matched. The reference image is 
placed at the center. Best suited for creating wide panoramas.

•	Spherical Similar to the Perspective layout option but creates gradually arcing upper and lower edges of the 
image border.

•	Collage Choose this option to open the source images in a dialog and position them manually for the best result.

•	Reposition Aligns the layers and matches overlapping content, but does not transform (stretch or skew) any of 
the source layers.

3.	 Click Browse, locate and select the files to be merged, and click Open.

The selected files appear in the Source Files list.

4.	 Make sure the Blend Images Together option is selected.	

5.  Click OK.

Figure 3 The Photomerge dialog box



4How to combine images  Photoshop Guide© 2016 Adobe Systems Incorporated. 
This document requires Adobe Photoshop CC 2017. Technical instructions may differ depending on your version.

Photomerge automatically combines your images into a panorama by using layers and masking (Figure 4). The 
masking is determined by the advanced blending feature in Photomerge. To turn a layer on or off, click the visibility 
icon in the Layers panel.

6.	 The next step is to crop your panorama to fill a rectangular frame. In the Tools panel, select the Crop tool and 
frame your panorama.

A Rule of Thirds grid appears with sizing handles and a crop preview appears in the Layers panel (Figure 5).

7.	 To crop your selection, press Enter (Windows) or Return (Mac OS).

8.	 Save your image.

Figure 4 Merged layers

Figure 5 Framing the final panorama
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Accessing Photomerge from Adobe Bridge
You can also begin the process of creating a panorama from Adobe Bridge. This is useful if you use Adobe Bridge to 
manage your image collections. Images in Creative Cloud Libraries can also be Photomerged. To learn how to work 
with CC Library images, see the Working with Creative Libraries guide.

To access Photomerge from Adobe Bridge:

1.	 In Adobe Bridge, select the images that will form a panorama.

2.	 In the menu bar, select Tools > Photoshop > Photomerge (Figure 6).

Photoshop starts and the Photomerge dialog box appears, listing the images you selected in Adobe Bridge.

3.	 Continue the process of creating your panorama as described earlier in this guide.

Figure 6 Photomerge from Adobe Bridge
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Creating a High Dynamic Range (HDR) image

The dynamic range (ratio of dark to bright regions) in the visible world far exceeds what can be displayed on a monitor 
or printed. Human eyes can adapt to very different brightness levels, but most cameras and computer monitors can 
reproduce only a fixed dynamic range. Photographers, motion picture artists, and others working with digital images 
must be selective about what’s important in a scene because they are working with a limited dynamic range.

High dynamic range (HDR) images open up a world of possibilities because they can represent the entire dynamic 
range of the visible world. Because all the luminance values in a real-world scene are represented proportionately and 
stored in an HDR image, adjusting the exposure of an HDR image is like adjusting the exposure when photographing a 
scene in the real world. This capability lets you create blurs and other real-world lighting effects that look realistic. 
Currently, HDR images are used mostly in motion pictures, special effects, 3D work, and some high-end photography.

You can create an HDR image using multiple photographs, each captured at a different exposure. In Photoshop, the 
Merge To HDR Pro command lets you create HDR images from multiple bracketed exposures into a single image that 
preserves the full range of light in a scene and creates some dramatic effects (Figure 7).

Taking photos for HDR images
Keep the following tips in mind when you take photos to be combined with the Merge To HDR command:

•	 Keep the camera steady. Secure the camera to a tripod.

•	 Capture many exposures. Take enough photos to cover the full dynamic range of the scene. You can try 
taking at least five to seven photos, but you might need to take more exposures depending on the dynamic 
range of the scene. The minimum number of photos should be three.

•	 Varying the shutter speed to get different exposures. Don’t alter the aperture to get different exposures since 
this changes the depth of field in each image and can produce lower-quality final results. 

Figure 7 Original images (left), and finished HDR (right) with correct exposure for both the exterior and interior
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•	 Don’t use auto-bracketting. In general, if you use your camera’s auto-bracket feature, the exposure changes 
are usually too small.

•	 Use a wide range of exposures. The exposure differences between the photos should be one or two EV 
(exposure value) steps apart.

•	 Use consistent lighting. Don’t vary the lighting; for instance, don’t use a flash in one but not the next.

•	 Use only a still life. Make sure that nothing is moving in the scene. Exposure Merge works only with 
differently exposed images of the identical scene. 

To create an HDR image:

1.	 Choose File > Automate > Merge To HDR Pro.

2.	 In the Merge To HDR Pro dialog box, click Browse, 
browse to select the images, and click Open.

The images appear in the files list (Figure 8). To 
remove an item, select it in the Merge To HDR Pro 
dialog box and click Remove.

Note: If you want to add a folder of images or images 
that are open in Photoshop, choose Folder from the 
Use menu or click the Add Open Files button.

3.	 (Optional) Select the Attempt To Automatically Align 
Source Images option if you hand held the camera in 
your hands when you photographed the multiple 
images.

4.	 Click OK.

Photoshop processes the images.

A second Merge To HDR Pro dialog box displays thumbnails of the images being used in the merged result, a 
preview of the merged result, a bit depth menu, and a slider for setting the white point preview (Figure 9).

Figure 8 Merge To HDR Pro dialog box

Figure 9 Merge to HDR preview with thumbnails
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5.	 If necessary, do one of the following to set the view options for the merged result preview:

•	 Click the Minus or Plus buttons below the preview image to zoom out or zoom in.

•	 Choose a view percentage or mode from the pop-up menu below the preview image.

6.	 Choose a bit depth for the merged image from the Mode menu and confirm Local Adaptation is selected for 
tone- mapping method.

You can output the merged image as a 32-, 16-, or 8-bit file. However, only a 32-bit file can store all the HDR 
image data.

Local Adaptation adjusts HDR tonality by adjusting local brightness regions throughout the image.

7.	 Adjust settings to preview the merged image:

•	 In 32-bit mode, move the slider below the histogram to adjust the white point preview of the merged image. 
To readjust the white point preview at any time, choose View > 32-Bit Preview Options.

•	 In 16- or 8-bit mode, move the Edge Glow sliders and the Tone And Detail sliders to refine the preview 
image.

8.	 Click OK to create the merged image. 

Photoshop processes the images to a one final HDR image (Figure 10).

If you chose to save the merged image as an 8-bit or 16- bit image, the HDR Conversion dialog box opens. Make 
the exposure and contrast corrections to produce an image with the dynamic range (tonal range) you want.

Figure 10 Final HDR image
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Accessing Merge To HDR Pro from Adobe Bridge
You can also begin the process of creating a high dynamic image from Adobe Bridge. This is useful if you use Adobe 
Bridge to manage your image collections. Images in Creative Cloud Libraries can also be merged to HDR. To learn how 
to work with CC Libraries images, see the Working with Creative Libraries guide.

To access Merge To HDR Pro from Adobe Bridge:

1.	 In Adobe Bridge, select the images that will form an HDR image.

2.	 In the menu bar, select Tools > Photoshop > Merge To HDR Pro (Figure 11).

Photoshop starts and the Merge To HDR Pro dialog box appears, listing the images you selected in Adobe Bridge.

3.	 Continue the process of creating your HDR image as described earlier in this guide.

Figure 11 Merge To HDR Pro from Adobe Bridge
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